【华为OD机试】寻找身高相近的小朋友(排序算法实现Java&Python&C++&JS)

题目描述:

给定一个学生信息列表,每个学生信息由姓名和身高组成。要找到身高最接近的小友。如果有多对小友身高相同,则输出字典序最小的一对。

输入描述:

学生信息列表,每个学生信息由姓名和身高组成,姓名和身高由空格分隔,学生信息由换行分隔。

输出描述:

找到身高最接近的小友的信息,姓名和身高之间用空格分隔。

示例输入:

Bob 120

Alice 130

Jane 110

示例输出:

Jane 110 Bob 120

解决方案:

Java 代码实现:




import java.util.*;
 
public class Main {
    public static void main(String[] args) {
        Scanner scanner = new Scanner(System.in);
        List<Student> students = new ArrayList<>();
        while (scanner.hasNextLine()) {
            String[] info = scanner.nextLine().split(" ");
            students.add(new Student(info[0], Integer.parseInt(info[1])));
        }
        Student[] closestFriends = findClosestFriends(students);
        System.out.println(closestFriends[0].name + " " + closestFriends[0].height + " " + closestFriends[1].name + " " + closestFriends[1].height);
    }
 
    private static Student[] findClosestFriends(List<Student> students) {
        students.sort(Comparator.comparingInt(s -> s.height));
        int minDiff = Integer.MAX_VALUE;
        Student[] closest = new Student[2];
        for (int i = 1; i < students.size(); i++) {
            int diff = Math.abs(students.get(i).height - students.get(i - 1).height);
            if (diff < minDiff) {
                minDiff = diff;
                closest[0] = students.get(i - 1);
                closest[1] = students.get(i);
            }
        }
        return closest;
    }
 
    static class Student {
        String name;
        int height;
 
        public Student(String name, int height) {
            this.name = name;
            this.height = height;
        }
    }
}

Python 代码实现:




import sys
 
def find_closest_friends(students):
    students.sort(key=lambda s: s.height)
    min_diff = sys.maxsize
    closest = [None, None]
    for i in range(1, len(students)):
        diff = abs(students[i].height - students[i - 1].height)
        if diff < min_diff:
            min_diff = diff
            closest[0] = students[i - 1]
            closest[1] = students[i]
    return closest
 
class Student:
    def __init__(self, name, height):
        self.name = name
        self.height = height
 
if __name__ == "__main__":
    students = []
    for line in sys.stdin:
        name, height = line.split()
        students.append(Student(name, int(height)))
    closest_friends = find_closest_friends(students)
    print(f"{closest_friends[0].name} {

评论已关闭

推荐阅读

DDPG 模型解析,附Pytorch完整代码
2024年11月24日
DQN 模型解析,附Pytorch完整代码
2024年11月24日
AIGC实战——Transformer模型
2024年12月01日
Socket TCP 和 UDP 编程基础(Python)
2024年11月30日
python , tcp , udp
如何使用 ChatGPT 进行学术润色?你需要这些指令
2024年12月01日
AI
最新 Python 调用 OpenAi 详细教程实现问答、图像合成、图像理解、语音合成、语音识别(详细教程)
2024年11月24日
ChatGPT 和 DALL·E 2 配合生成故事绘本
2024年12月01日
omegaconf,一个超强的 Python 库!
2024年11月24日
【视觉AIGC识别】误差特征、人脸伪造检测、其他类型假图检测
2024年12月01日
[超级详细]如何在深度学习训练模型过程中使用 GPU 加速
2024年11月29日
Python 物理引擎pymunk最完整教程
2024年11月27日
MediaPipe 人体姿态与手指关键点检测教程
2024年11月27日
深入了解 Taipy:Python 打造 Web 应用的全面教程
2024年11月26日
基于Transformer的时间序列预测模型
2024年11月25日
Python在金融大数据分析中的AI应用(股价分析、量化交易)实战
2024年11月25日
AIGC Gradio系列学习教程之Components
2024年12月01日
Python3 `asyncio` — 异步 I/O,事件循环和并发工具
2024年11月30日
llama-factory SFT系列教程:大模型在自定义数据集 LoRA 训练与部署
2024年12月01日
Python 多线程和多进程用法
2024年11月24日
Python socket详解,全网最全教程
2024年11月27日